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OpenOffice.org Writer 
     
Creating and Saving Documents  
 
Starting OpenOffice.org Writer 
 
 OpenOffice.org Writer can be started or run in several ways. We show here just one method and that too concentrating on 
NepaLinux. 
 
To start OpenOffice.org Writer in NepaLinux, you would need to do the following, Applications-> Office-> OpenOffice.org 
2.2 Writer . This is shown in Pic.1. below. 
 

 
Pic. 1. Starting OpenOffice.org Writer in NepaLinux 
 
Getting introduced with menus and toolbars 
 
OpenOffice.org Writer like any other word processing application comes up with the main menu that is located at the top 
most part of the OpenOffice.org Writer window immediately below the file's title bar. Immediately that follows the main 
menu is the standard toolbar which contains the iconic buttons for "Creating a New File", "Opening a File", "Saving the 
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File" and so on. On the third line we have the formating menu bar that basically has the formating elements like changing 
the position (Left, Middle, Right, Justified alignment buttons for texts), selecting the fonts, font size, text indent, text color, 
highlight color and so on. The three menus are shown in Pic.2. 
 

Pic.2. Menus and toolbars in OpenOffice.org Writer 
 
Besides the standard toolbar, there is also the Drawing toolbar towards the bottom of the window, which is shown in Pic.3. 
In case, this is not seen in your OpenOffice.org Writer window, you would need to go to View->Toolbars in the main menu 
and check out Drawing. 
 

Pic.3. Drawing toolbar 
 
The drawing toolbar is basically used to develop drawings within OpenOffice.org Writer documents. 
 
Typing and editing documents 
 
The first time you run OpenOffice.org Writer, you are displayed a new or a blank page as shown in Pic.4. Alternatively, a 
blank page is displayed either by clicking on the "New" button from the standard tool bar or choosing File->New-> Text 
Document in the main menu. 
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Pic. 4. A new blank page of OpenOffice.org writer 
 
You may start typing from the point the cursor of your mouse is blinking. For instance, in the above picture, it is the black 
line that is seen on the left most end of the page. As far as editing documents is concerned, one would need to open an 
existing file. For this, you may either click on the "Open" button from the standard tool bar or choose File->Open... 
Once either of these actions are done, you would be displayed the "Open" dialog box as shown in Pic.5. 
 
 

 
Pic. 5. Open dialog window for opening files 
 
After selecting the required file and then clicking on the "Open" button, the file would be opened in the OpenOffice.org 
Writer window. This is shown in Pic.6. 
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Pic. 6. A file opened through OpenOffice.org Writer for editing 
 
Correct spelling mistakes manually and with the AutoCorrect function 
 
So that the auto spellcheck and autocorrect options are enabled for your language, you would need to go to Tools->Options 
in the main menu. As a result, the following dialog window is displayed as shown in Pic.7.  
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Pic.7. Options dialog window 
 
Here please expand the "Language Settings" node in the left hand side of the window and select "Writing Aids". On the  
options displayed on the right handside of the window, please make sure that you check the Option "Check in all 
languages". Then, only your system would be able to autocorrect the spelling mistakes in your document. 
 
When you run OpenOffice.org Writer, it could be that the AutoSpellCheck is not enabled. To enable it, you would need to 
click on the "AutoSpellCheck" button in the standard toolbar. As you type, the words that have been typed incorrectly would 
be marked in red as shown in Pic.8. 
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Pic.8. Demonstration of AutoSpellCheck command 
 
By simply, right clicking your mouse over the word would display a pop up menu with suggestions. You may select an 
appropriate suggestion from the suggestion list. This is shown in Pic.9. 
 

 
Pic.9. Suggestion and other options for the incorrect word 
 
 
As you see in Pic.9, you may opt to choose "Typing" as an appropriate suggestion or even add to the dictionary 
(standard.dic) the word if you are certain that the word that you have typed is correct. You may also opt to ignore all. This 
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option would ignore all the words of this particular spelling in the document so that the red marks are unmarked. You may 
also prefer to autocorrect the word with the suggestion put forward by OpenOffice.org Writer. In that case, if you happen to 
type "Typong" somewhere later in the document, it changes to "Typing" as soon as you have finished typing. 
 
There is also a manually spellcheck option available for which first you disable the "AutoSpellCheck" button from the 
standard tool bar. In order to disable the "AutoSpellCheck" button, all you would need to do it is click on it. 
 
Now say that you have typed the word "hitsa" and would like to manually spellcheck it. In that case, all you would need to 
do is focus the mouse cursor on the word and then click on the "SpellCheck" button on the standard toolbar. As a result, the 
following window is displayed as shown in Pic.10. 
 
 

 
 
  
Pic. 10. Spellcheck window for manually spell checking a particular word 
 
As in the previous case of of the popup menu with suggestions, here too, you can see a lot of options like "Ignore once", 
"Ignore All", "Add", "Change", "Change All", "Autocorrect", "Close" etc. 
 
The designation of these several options have been discussed earlier. 
 
The above discussion assumes that OpenOffice.org Writer has the required dictionaries and other files required for spell 
checking for your language. 
 
Giving a name to a document and saving it 
 
There are several ways to save a particular document under some given name. 
 
If you have just created a document and not yet saved it under a particular name, your file title bar would show "Untitled1 – 
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OpenOffice.org Writer" as shown in Pic.10. 
 
To save this document, you may either go to File->Save As... or just click on the "Save" button in the standard toolbar. As a 

 
ic. 11. Save as dialog window 

 the above window, if you notice to the upper right corner, you will see three iconic buttons. These are respectively, "Up 

Pic. 13. Iconic buttons for determining the fi

e help of these buttons for saving the file. 

d need to specify the file 

result of which you would be displayed the following window as shown in Pic.11. 
 

P
 
In
one level", "Create New Directory" and "Default Directory" and is shown in Pic.13. 
 

le location 
 

ou may navigate to the right folder or directory with thY
 

ext, you would need to give a proper name to the file in the File name text box. Besides, you woulN
type of the document being saved. If you click on the combo box for File type, you will see a number of options as shown in 
Pic.14. 
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Pic.14. File type variants 
 
By default, OpenOffice.org Writer saves documents in OpenDocument Text(.odt) format. But you may choose any other file 
type as well. However, you are advised to save your documents under Microsoft Word 97/2000/XP (.doc) if you plan to later 
open and make changes in the Windows platform. 
 
Bringing in more tools from the View -> Toolbars menu 
 
In order to bring in more tools from the View->Toolbars menu, you would need to check out all the tools that you are 
interested from the window below shown in Pic.15. 
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Pic. 15. Adding more tools from the View->Toolbars 
 
Editing Documents  
 
Opening existing documents and saving them in some other names 
 
Opening existing documents and saving them in some other names is as simple as selecting File-> Save As.. 
In the Save As.. window, put some different name in the File Name and click on the "Save" Button. 
 
Cutting, copying and pasting fragments of texts within the document 
 
Cutting, copying and pasting fragments of texts within the document is an important part of document editing.  You will find 
these tools under the Edit menu in the main menu and also on the standard toolbar. You will also find them in the contextual 
popup menu that comes when you right click your mouse. Each of these options are shown in Pic. 16, 17 and 18. 
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Pic. 16. Cut, copy and paste submenus under main menu Edit 
 
 
 
 
 

 
Pic.17. Cut, copy and paste buttons in between AutoSpellCheck and Format Paint Brush options 
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Pic.18. Contextual popup menu on highlighting a particular text fragment and right clicking of the mouse for Cut and Copy 
  
Say for instance, you want to cut the previous sentence and place it elsewhere. In that case, you would need to select the 
sentence by putting the cursor at the beginning of the sentence, then pressing the left button of the mouse and moving the 
mouse till you have selected the whole sentence. Please take note that as you move the mouse, you can see the text 
higlighted in black. Then right click your mouse keeping your mouse focussed on the highlighted text in black. This is 
shown in Pic.19. 
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Pic. 19. The selection of text for being cut with the contextual popup menu being displayed. 
 
If you then select Cut, the highlighted  text would be removed as shown in Pic. 20.  
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Pic. 20. Removal of thehighlighted text by the use of the command Cut 
 
 
Undoing and redoing changes 
 
If you would need to cancel a particular action that you have done, you may simply choose Edit->Undo from the main menu 
or press Ctrl+Z. Selecting several times would serially revive the initial states. For instance, if you had cut a particular 
fragment of text, entered right before that and typed something before that, then Undoing serially three times will take you 
back to point where you were before typing. 
 
Redoing something is the reverse of Undoing something. For instance, you decided to cancel something and chose Undo. 
Obviously your previous action would be cancelled. Now that you want the action to revive, in this case, you choose Edit-
>Redo 
 

 
 
Pic. 21. Undo and Redo submenus under main menu Edit  
 
Inserting objects, pictures and contents from files 
 
To insert objects, pictures and contents from files, you would need to go to the Insert menu in the main menu. Pic.22 shows 
the submenus under the Insert menu. 
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Pic.22. Submenus under the Insert menu 
 
As you choose Picture, you would be further asked the source from where you are inserting the picture. In most cases, it is 
from the files, so please select From File..  
 
You would be led to the standard "Insert Picture" dialog window from where you would need to select your desired picture. 
 
All the pictures inserted in this document have been done this way, For inserting objects like formula, chart, applets etc., 
you would need to select Object submenu under the Insert menu. The Object submenu and its options are shown in Pic.23. 
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Pic. 23. Object submenu under Insert menu 
 
Once you click Formula, you will see an outlined dotted box appearing in your page. This is the place where you will have 
the formula displayed. Besides, you will also be displayed the formula editing page and the set of formulae displayed in the 
Selection bar. A picture of all of these is displayed in Pic.25. 
 
 
Pic. 23. Inserting Formula as an object. 
 
 
Formating text and paragraphs  
 
Formatting text and paragraph carries a very wide meaning.  The activity ranges from text alignment, i.e positioning the text 
to the left, right, middle and justified) to making the text bold, underlined or italicized. Changing the text color or the 
highlight color also fall under formatting. These are just a few details about the formatting activity. 
 
Formating text 
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Inorder to format a text, the formatting toolbar is available in the third pane of the menu bars. This can be seen in Pic.3. As 
you can see the format menu bar has a combo box with a collection of different font names. To it's side, you can see the font 
size. Selecting the text and applying a particular font and font size, you can see the formatting effects. Besides, clicking on 
the Bold, Italic and Underlined Buttons, you will have the corresponding effects in the selected text. If you want to select  
the complete text in the document, you would need to choose Edit->Select All or press Ctrl+A. The effects of selecting the 
Bold, Italics and Underline Button for a particular text is shown below. 
 
 
YOU CLICKED THE BOLD BUTTON. 
YOU CLICKED THE ITALIC BUTTON.  
 
YOU CLICKED THE UNDERLINE BUTTON. 
 
Beside the Underline Button, you will find two useful buttons for entering simple indices and power numbers. For instance 
with the Superscript button, you may express powered numbers where as with the help of the Subscript, you can express 
indices. This is shown below. 
 
Use of Superscript – x2 

 
Use of Subscript – x2 
 
 
The four forms of text and paragraph allignment is also shown below: 
 
 
Applying left align  
 
I still remember my first salary. It was a huge sum, it was hard-earned, it was much awaited, it was mine! Till the time I lay 
my hands on the money, I thought I was the most wise person with money. Extravagance was not my cup of tea. When I 
was a child, I'd tell my mom that I'm going to use half of my salary on charity. When she'd remind me that I could very well 
use my pocket money to do so, I'd brush it off saying it is not enough. Both of us waited for my first pay. And again, it is not 
enough! 
 
Applying centered align 
 
I still remember my first salary. It was a huge sum, it was hard-earned, it was much awaited, it was mine! Till the time I lay 

my hands on the money, I thought I was the most wise person with money. Extravagance was not my cup of tea. When I 
was a child, I'd tell my mom that I'm going to use half of my salary on charity. When she'd remind me that I could very well 
use my pocket money to do so, I'd brush it off saying it is not enough. Both of us waited for my first pay. And again, it is not 

enough! 
Applying Align Right 
 

I still remember my first salary. It was a huge sum, it was hard-earned, it was much awaited, it was mine! Till the time I lay 
my hands on the money, I thought I was the most wise person with money. Extravagance was not my cup of tea. When I 

was a child, I'd tell my mom that I'm going to use half of my salary on charity. When she'd remind me that I could very well 
use my pocket money to do so, I'd brush it off saying it is not enough. Both of us waited for my first pay. And again, it is not 

enough! 
 

Applying Justified 
 
I still remember my first salary. It was a huge sum, it was hard-earned, it was much awaited, it was mine! Till the time I lay 
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my hands on the money, I thought I was the most wise person with money. Extravagance was not my cup of tea. When I 
was a child, I'd tell my mom that I'm going to use half of my salary on charity. When she'd remind me that I could very well 
use my pocket money to do so, I'd brush it off saying it is not enough. Both of us waited for my first pay. And again, it is not 
enough! 

 
 

 
Increasing and decreasing indent of text 
 
If you want to increase or decrease the starting point of a particular text, you may use the Increase Indent and Decrease 
Indent. 
 
The initial position before applying indent. 
 
I still remember my first salary. It was a huge sum, it was hard-earned, it was much awaited, it was mine! Till the time I lay 
my hands on the money, I thought I was the most wise person with money. Extravagance was not my cup of tea. When I 
was a child, I'd tell my mom that I'm going to use half of my salary on charity. When she'd remind me that I could very well 
use my pocket money to do so, I'd brush it off saying it is not enough. Both of us waited for my first pay. And again, it is not 
enough! 
 
After applying Increase Indent 
 

I still remember my first salary. It was a huge sum, it was hard-earned, it was much awaited, it was mine! Till the 
time I lay my hands on the money, I thought I was the most wise person with money. Extravagance was not my cup 
of tea. When I was a child, I'd tell my mom that I'm going to use half of my salary on charity. When she'd remind 
me that I could very well use my pocket money to do so, I'd brush it off saying it is not enough. Both of us waited 
for my first pay. And again, it is not enough! 

 
 
After applying Decrease Indent to the same text above. 
 
I still remember my first salary. It was a huge sum, it was hard-earned, it was much awaited, it was mine! Till the time I lay 
my hands on the money, I thought I was the most wise person with money. Extravagance was not my cup of tea. When I 
was a child, I'd tell my mom that I'm going to use half of my salary on charity. When she'd remind me that I could very well 
use my pocket money to do so, I'd brush it off saying it is not enough. Both of us waited for my first pay. And again, it is not 
enough! 
 
Changing the font color 
 
Next to the text indentation, you will see the Font Color button. If you click on it, you will see a range of colors. Once you 
select a partcular color from the set, the text will attain that color.  
 
 
 Further in the right most corner of this format tool bar panel, you will see two arrows pointing to the right. This is shown in 
Pic. 24. 
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Pic. 24. Adding more visible buttons to the formatting tool bar panel 
 
Sometimes, it may be that not all buttons are visible in the format tool bar panel. In that case, you would need to check out 
the unchecked boxes in the list being displayed on having clicked Visible Buttons. 
 
Bullets and Numbering... 
 
Bullets and Numbering is an important part of formatting. Basically, they are used for enumerating lists. The Bullets and 
Numbering.. can be accessed by selecting Format -> Bullets and Numbering ... 
 
This is shown in Pic.25. 
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Pic. 25. Bullets and Numberings... 
 
As you click Bullets and Numberings..., you will be displayed the following window as shown in Pic.26. 
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Pic.26. Bullets and Numbering window 
 
Clicking to one of the options in these tabs, you may define the nature of your bullets and numberings. 
 
For illustration, we present below both bullets and number formats for enumerating lists. 
 
 
Using the bullet 
 
Drinks on the menu 
 

 Hard 
 Whiskey 
 Wine 

 Soft 
 Coke 
 Mineral water 

 
Using the numbers 
 
Drinks on the menu 
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1. Hard 
hiskey 

2. 
oke 

l water 
 

or the bullets and Numbering, the following set of tools are very useful components. If the window shown in Pic. 27. is not 

 
ic. 27. Bullets and Numbering window 

he left most button in this window is the Bullets on/of f button. While developing lists, clicking this button once would 

sing the Format Painter 
ou will see a button with the icon of a paint brush just beside the Paste button in the standard 

reviewing and printing documents 

reviewing and printed  the documents that you have prepared is a very necessary and a day to day encountering activity. 

xporting the document to PDF format 

penOffice.org Writer has one very useful utility inbuilt in it. This is the possibility of exporting the document to .PDF 
 tool 

reviewing the document before sending to the printer 

 1.1  W
 1.2  Wine 
Soft 
 2.1  C
 2.2  Minera

 
F
visible, then it is not probably checked out in View->Toolbars. Kindly check it out. 
 
 

P
 
T
create a bullet whereas reclicking on it would lead to the removal of the bullet. The other button is the Numbering on/off. 
Same thing applies to clicking and reclicking this button as in the case of the previous button but in this case it deals with 
numbers. The other buttons like “Promoting one level”, “Demoting one level”, “Promote one level with Subpoints”, 
“Demote one level with Subpoints ” are useful in managing the hierarchy of list items. 
 
 
U
If you look back at Pic.3., y
toolbar. This is the Format Paint Brush Button. It has a very useful application. Sometimes, you would need to apply a 
particular formatting that you have already applied to a particular fragment of text to some other text fragment within the 
document. In this case, you select the previous formatted text and click on the Format Painter Button. Doing this would 
copy the format of the text. Then just select the other fragment of text and release the mouse's left button. You will see that 
the format of the previous text has been well transfered to the current text. 
 
 
P
 
P
Before printing documents, you would need to ensure that they are in the right format and form. 
 
E
 
O
version from within the application itself. For this, you may click on the "Export directly as PDF" button in the standard
bar panel or choose File->Export as PDF... from the main menu. 
 
 
 
 
P
 

23 



You may preview a page in two different ways, either by clicking on the Page preview button located at the standard toolbar 

s a result the following window is displayes as shown in Pic. 28. 

ic. 28. Preview Page window 

 the page preview mode, if you scroll the scroll ball of the mouse, you will be able to view the rest of the pages in the 

hanging page parameters before printing 

ou may change the page parameters before printing by selecting File->Print... 

or by choosing File-> Page Preview 
 
A

 
P
 
In
document. As you click on the Close Preview Button, you will return to the normal mode. 
 
C
 
Y
As a result, you will see the following window as shown in Pic. 29.  
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Pic. 29.  Print window 
 
If you then click on Properties...  button, then you will be displayed the following window as shown in Pic.30. 
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Pic.30. Paper parameter window 
 
 
Printing the complete document or just partially 
 
If you look back in Pic. 29., you may opt to print the whole document by opting Print Range – All or only some pages by 
opting pages and specifying the particular page or a range of page numbers. This way, you can print the document partially 
as well. 
 
       
Using OpenOffice.org Writer Help  
 
OpenOffice.org Writer  has a rich Help incorported with the application. To access the Help, you may press F1 or choose 
Help->Openoffice.org Help 
 
You will be displayed the following window as shown in Pic.31. 
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Pic. 31. OpenOffice.org Help 
 
You may enter anything that you would want help for in the Search term text box. If there is one, you would displayed in 
detail about the term in the right side of the window as shown above. 
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