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1. Logging in and Logging out
Logging in Graphically:

During the time of NepaLinux Installation, users are asked to create at least one user account. Users
must provide this username and the corresponding password to be able to login into the system. the root
user is generally not used to login into system because of the security reasons.

When users login for the first time users are asked to which language they want their Desktop
environment, once you set this language it remain as it is. To switch the language for example to Nepali
environment, you have to go through KDE control center. For details about it please refer to the section
“‘control section”.

Logging out:

Click on the Main menu and click on Log out. User can also select between the options to Turning
off , restarting and logging out.

2. KDE Desktop general overview:

KDE is a network transparent contemporary desktop environment for UNIX workstations. KDE seeks
to fill the need for an easy to use desktop for Unix workstations, similar to the desktop environment
under MacOS and Windows environment.

NepaLinux 3.0 KDE consists of koffice suite for office productivity, Konqueror for file and web
Browser, KPPP for configuring Modem and Kmail for mail client. Apart from these it includes several
other utilities for Multimedia, Graphics, education and games.

Main components of Desktop

There are three main components on the KDE Desktop.
* The Menu

* The Panel

* The Desktop itself

The Menu System
The main Menu can be accessed by clicking on the Main Menu button located at the extreme lower left

hand corner of the Desktop.
The Menu may be protrayed by one of several icons depending upon the Desktop environmet used.

hd

Fig. Generic KDE main Menu button.



Clicking on this will bring up the menu system as shown.

Most Used Applications ]B Lock Session
W Control Center [0] Log out...
¥ Help
‘Fj Screen Capture Program (KSnapshot)

All Applications l

|5l Debian J
' Edutainment r
—f:.-h Games L
= Graphics L
Q Internet k
:9 Multimedia k
€ Office »
=, Settings k
@y system b
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© AddfRemove Programs
W Control Center

t;.] Find Files/Folders
¥ Help

ﬁ Personal Files (Home)

Actions
4 -\, Settings r
M | System Menu r
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From Menu system we can start any of the programs installed in our NepalLinux system. Note that
Menu system consists of main Menu Panel and sub Menu Panel. Each entry in the Menu System which
has an arrow on its right means that it is an entry point to a sub-menu, and there can be sub-menus
within each sub-menu.

The Panel



The long bar across the bottom of the desktop screen is called the Panel. The Panel contains the Main
Menu icon, the application launcher icons, a notification area and applets.

Applets

Applets are small applications that run on the Panel. You can add the Applet to the Panel by right
clicking the panel and selecting "add applet to the panel".

M Add Applet - KDE Panel 2 O X

Search: l l Show: [AII vl

= Detect and end broken processes which consume too much [
CPU time

Eﬁ Settings

Control Center modules menu

Show Desktop

A button that gives guick access to the desktop when

Sound Mixer E

Add to Panel H Close l

For example to add the Show Desktop applet to the Panel select the Show applet in the applet menu.
The Desktop
The Desktop space refers to the rest of the screen.

The File Manager:

KDE includes very versatile and powerful file manager called Konqueror which allow you to do
everything with the files stored in the computer. If you want more details about what Konqueror take
a look at the Konqueror Handbook by selecting Help->Konqueror Handbook in the Konqueror menus;
or, alternatively, you can use the help in Konqueror by entering help:/konqueror in the Location
Toolbar.

Folders:

You can open any item by clicking just once on the icon for the file.(since KDE doesn't use double-



clicking in its default settings).Folder will be opend in the same window or in the appropriate program.
You can go back to the last folder by clicking on the Back button or go up by clicking the up icon.

The Navigation Panel (aka The Sidebar)
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Fig. The Konqueror sidebar
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Navigating through the folders by using the folder view can become impractical. The sidebar provides
shortcuts and special functions that make it easier to find what you are searching for. On the left edge
of the sidebar you will find a number of buttons, each with a different icon.

Bookmarks
As Konqueror (the file manager) also serves as a very powerful web browser, it also has a bookmark
functionality. Here you will find the same structure as in your Bookmarks menu.

History
Konqueror will remember the web pages you have visited and list them either by date or alphabetically
in a tree structure

Home Folder
The Home Directory item is in the sidebar's navigation panel. You will find your home directory as the
first entry.

Root Folder

Everything on a UNIX based system is organized in a file system tree. The Root Folder function is like
the Home Folder function. The only difference is that every folder is being displayed, not only your
home directory.

Network

Here you can browse the services provided by other computers on the network. The network browser
allows you to see a variety of services provided by a computer. You can easily browse SMB shares,
HTTP sites.

The Trash

The file is moved to the Trash folder when you delete the file before it is permanently removed, so that
there is possibility of getting it back if you deleted it by accident. For restoring the file select the file
and move it to the original place. If you right click in the Trash bin and select Empty Trash Bin, then
the files will be deleted permanently.

References: KDE online Manual

http://docs.kde.org/development/en/kdebase/userguide/index.html

3.Using common Mass storage


http://docs.kde.org/development/en/kdebase/userguide/index.html

The more common peripherals include:

Printer
Scanner
Mass storage devices

We shall be looking at how to access and use the common peripheral mass storage devices,

Floppy disk drive
CD-ROM drive

USB mass storage device
CD-RW drive

Printer Setup:

If you have a printer attached to your system you will need to configure and set it up before you can
use it properly. To do this,

1.KDE Menu ----> Control Center ----> Peripherals ----- > printers

2.Now click on Administrator mode (You are asked to enter the root password)

3. At the printer configuration screen click on the Add --> Add Printer/Class menu to add and
configure a new printer.

4. The add new printer wizard will be displayed.

W Add printer wizard e

Introduction

Welcome,

This wizard will help to install a new printer on your cormputer. It will guide you
through the various steps of the process of installing and configuring a prirter for
your printing system. At each step, you can always go back using the Back
button.

We hope you'll erjoy this toal!

The KDE printing team.

Mext = I l Cancel




5. Select the local printer or Network printer.

I Add Printer Wizard = =] s

Backend Selection

@ Local printer (parallel, serial, USB)
) Remote LPD queue

2 SMB shared printer (Windows)

) Metwork printer (TCP)

) Remote CUPS server (IPP/HTTR)
) Metwork printer wfIPP (IPRJHTTP)
D

) Other printer type

) Class of printers

<= Back l | MNext = ] [ Cancel

6. select how your computer is connected to the printer (the 'port').

7. Once you select the port , click Next.

8. Select the manufacturer of your printer, and then your specific printer from right side.
9. Then click Next.



Network Printer:
1.Select network printer and click Next.

& Add Printer Wizard ?2 0O X

Backend Selection

() Local printer (parallel, serial, USB)
() Remote LPD queue

) SMB shared printer (Windows)

() Network printer (TCP)

() Remote CUPS server (IPP/HTTP)
® Network printer w/lPP (IPP/HTTP)
a

() Other printer type

() Class of printers

=402, Provide the URL for the
path.

IPP Printer Information

Brinter LRI
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Either enter the printer URI
directly, or use the network

scanning facility.
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[ Settings H Secan ]

[ < Back H Next > H Cancel ]




3. Select the proper manufacturer and the Model for the Printer.

% Add printer wizard el

Printer Model Selection

Manufacturer: Model:
Cas=ij=l LLow
EFSON = Laserjet 1100A -
FUJITsSU Laserlet 1150
GEMERIC Laser]et 1200
GESTETMER |: Laserjet 1220
HEIDELEERG
HITACHI

Laserjet 1320
Laser]et 2
Laserjet 2 w/PS

g Laserjet 2100
Laserlet 21 00M

[ ] PostScript printer

[ ] Raw printer (no driver needed)

[ < Back H Mext = H cancel ]

IMAGEM
INFOTEC

4. Click Next and provide the other required information such as printers name, location etc.

Mass Storage Device:
USB Mass storage device

Another popular portable storage medium is the USB mass storage device. (Flash Drives)



" 128M Removable Media - KDE Daemon

\ F .
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Do Mothing
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Configure... H QK H Cancel l

As soon as you enter your USB disk this pop up menu appear. You can click Open in New Window
and browse you USB disk.

To safely remove your USB disk, click

System ------- > Storage Media ----- > right click USB drive icon and click safely remove.

As of USB Disk , when you enter CD-ROM, or DVD-ROM it will be automatically detected and pop
up menu appear in your Desktop. Similarly you can access the Floppy Drive from the System----->
Storage Media ----> Floppy Disk.

CD/DVD Burner (K3B)

K3b is a CD and DVD burning application which provides a comfortable user interface to perform
most CD/DVD burning tasks like creating an Audio CD from a set of audio files , copying a CD or
DVD, Making data CD or DVD and writing ISO.

To use this k3b, start the K3b program from the Main Menu.

Main Menu --> Multimedia --> K3b



fit K3b - The CD and DVD Kreator
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4. The KDE Control Center
It is a place where you can change any settings that affect the whole of your KDE environment. You
can open it from the using the Control Center item in the K menu.

The settings are divided into several major categories, which each contain several pages of settings. To
display a settings page, expand the major category by clicking on the + button next to it, and then click
on the name of the page you want. The settings page then appears on the right, and you can change
settings to your heart's content. No changes take effect until you click on the Apply button. If you
decide, after making some changes, that you want to leave the settings as they were, just click on Reset.

Appearance & Themes

Here you will find settings that change the way your KDE desktop and applications look. In this section
you can change background, colors ,fonts, Icons, style, themes etc.

Desktop

This is where you will find settings to configure the appearance and behavior of your KDE desktop.

Here you can change behavior, multiple desktop setting, panels,taskbar etc.

Internet and Network
Here you can set the setting for Internet and Network, such as IP assignment, File sharing etc. The



detail in this setting will be covered in the ‘“Networking with KDE “section.
KDE Components

In this section you can modify advance KDE options such as file associations and default applications.
For example in the file composer section you can define what Email Client, Embedded Text Editor,
Instant Messenger, Terminal Emulator and Web Browser to use.

Peripherals
you can change setting related to peripherals such as keyboard, mouse , display printers etc. for
example you can change the display setting through this section in the control center.

Power control

This section has a single module, Laptop Battery. Here you can configure the appearance and behavior
of the Klaptopdaemon battery monitor. You can select battery icons to represent different power states,
and set up notification of certain events. In the case that your battery runs down to a critical level, you
can configure the daemon to suspend or shutdown your laptop, to save you from losing data.

Regional & Accessibility

This section is where you can configure options to do with region and locale. You can switch your
login environment to another language from this section for example Nepali to English and vice versa.
To change the login environment to English click add language tab and select English, then move it up
to make it default. Your setting will take place next time you login.

In this section you can also configure keyboard layout. The detail about the keyboard layout is
explained under the section “Font Installation and Keyboard Layout”

Security & Privacy

This section is where you can configure options related to security and privacy such as the use of
cryptography, setting your identity and managing caches.

System Administration
As the name implies this contains the section to configure administrative tasks such as installing fonts,
login manager, and Date and Time.

5.KDE and the Internet

Konqueror
Konqueror is not just a web browser but is also an advanced File Manager and Universal viewing



application.

Location Edit Wiew Go Bookmarks Tools Settings Window Help

OO0V WRIAAAESs &)
B Lgcation:|| |'I_J._J_J

0 u
Home Folder | Storage Media
Your personal files ~—2 Disks and removable media
MNetworl Folders | Trash
Shared files and folders Browse and restore the trash
C{m Applications ﬁ Settings _
28 Installed programs Deskiop configuration

L4 Mext: An Introduction to Kongueror

.1

Konqueror as a File Manager:

Kongqueror is an advanced file manger for the K Desktop Environment, providing the file management
functions ranging from simple cut/copy paste operations to advanced local and remote network file
browsing. File and folder properties can easily be examined and changed and application lunched with
a simple click of the left mouse button.

Konqueror as a web browser:
Konqueror is an excellent web browser with built in support for JavaScript , CSS, bidirectional scripts.
Kongqueror is also an excellent full featured FTP client.

Note: Konqueror by default does not support the gmail standard view. To support the standard view,
follow the following steps

Konqueror --> Settings --> Configure Konqueror --> Browser Identification



Click on New... and add mail.google.com and select identification Firefox 1.0.7
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Konqueror as application viewer:

Konqueror is also a universal viewing application, capable of displaying images and documents

without having to launch another application.
Seamonkey Web Browser

KDE also includes seaMonkey web Browser. KDE Menu ----- > Internet -------- > SeaMonkey Web

Browser.
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Mail Client Kmail:
KMail is a mail client. With Kmail you can browse your mail online or you can download your mail
and read it offline. Follow the steps below to setup Kmail.

1. Open KDE Menu ---> Internet ---> Mail Client (KMail)
2. Select POP3 or IMAP in the Account Type
3. Provide your full name email id and organization Name

# Local Folders/inbox - KMail

File Edit Wiew Go Folder Message Tools Settings Help

MEd= e 09 U]
I|Fo|der - |Unread |Total | B Search: [ ] Status: [QAny Status |,]
o [ELocal Fo...

e |Subject | Sender | Date (Order

& outbox
[ sent...
& trash
J drafts
i, Searches

| 0 messages ||

4. Provide your full email address in the login name field and provide password.

5. Provide POP3 server name. It is the name of the server where your mails will be collected

6. Provide SMTP server name. It is the name of the server through which your mail will be sent out.
Get this name from your ISP.



 kmail

Server Information

Incoming server: |mai|.|ins.cnm.np

| | Use secure connection (S5L)

Qutgoing server: |smtp.wlin|~c.cum.np|

| | Use secure connection (S5L)

| | Use local delivery

| < Back | | Finish | | Cancel

7. And click on finish.



Instant Messanger (Kopete)

Kopete is an instant messenger supporting AIM, ICQ, MSN, Yahoo, Jabber, IRC, Gadu-Gadu, Novell
GroupWise Messenger, and more.

1. Run Kopete from
KDE Menu ----- > Instant Messenger (Kopete)

HEA  HEq AT HEd

&2 AEE

o i |

» kopete 70X

TS & T 3T e SfETT *\'11{\6‘1,50'62?

L | it

‘ &AM Protocel to connect to Al
tGadu-Gadu Protocol to connect to Gadu-Gadu
/ (HGroupWwise Movell GroupWise Messenger
/ @ca Protocol to connect to ICQ
/ “WIRC Protocol to connect to IRC

'y Jabber Protocol to connect to Jabber

yIMSN Messenger Protocol to connect to MSN Messe...

T Meanwhile Meanwhile (Lotus Sametime) Proto...
Fsms Protocol to send SMS messages
(HTestbed Kopete test protocol

$winPopup Protocol to send Windows WinPapu...

ocol to connect to Yahoo

| [ | [




2. Now select the proper protocol for instant messaging depending upon your mail ID .for
example if your mail ID is of yahoo, select the yahoo protocol.

3. Provide the valid user ID and password.

4. Now click Next. Then after you are connected you are presented with your friends list.

IRC Client

KDE has its own IRC client called Ksirc.
1. Run it from KDE Menu ------- > Internet -------- > IRC Client (IRC)
2. To connect to the required channel click connect ----> New server
3. Then select the proper Groups of the channel, Freenode is the best channel for free and open
source software and other Linux related support. NepaLinux also has its IRC channel in the
freenode.

Now to join the channel type /join #<channel -name > for example to join the Nepalinux IRC channel, /
join #nepalinux.

#nepalinux (+stnd nepali () <limit: 20>T: Welcome to #nepalinux. Ne — O X

Channel Edit Users Command Window Settings Help

Welcome to #nepalinux. Nepalinux is http://nepalinux. org, Nepalinux 2.0 was released on Wed
@ Topic for #nepalinux: Welcome to #nepalinux. Nepalinux is ht -
tp:ffinepalinux.org. Mepalinux 2.0 was released on Wed, June 20.
Download it from f£p:f202.79.37.1 77 /nepalinux/ & have a

+0 ChanServ

daya
ity
arunakarg
@ Topic for #nepalinux set by ChanServ on Sun Jun 24 08:49:41 -
— nepali
rajol
il Users on #nepalinux: nepali karunakarg subir prajol daya el
bi
thamr @ChanSery subir
» You have joined channel #foss-nepal iz s
| Lag: 1.87

+r #nepalinux, #foss-nepal #debian l #nepalinux [ L #foss-nepal o #debian ‘

Configuring the Modem (KPPP) :

To configure your modem for Internet access, start the “Internet Configuration Wizard” tool from the
Main Menu:



Kde Main menu --> Internet --> Internel Dial-Up Tool (KPPP):

6. Customizing the Appearance of your KDE

Appearance and Themes
The appearance of KDE can be customized in different ways. It can either be done by changing the
theme or by changing the different components like desktop background, icons, etc.

Desktop Background

The desktop background, which is also known as wallpaper, can be changed either by going to the
Control Center or by right-clicking on the desktop.

First Method:
Go to Kmenu and click on the Control Center

On the 'Appearance and Themes', choose Background

Second Method:
Right-click on the desktop background
Choose 'Configure Desktop'

Both of these methods will take you to the same point from where you can change the desktop
background.
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Fig. Changing the background image

To change the desktop background,
Click on the radio button marked Picture’
Choose from the drop-down list

If you want to choose any other image of your choice apart from the ones shown in the list, click the
'Open dialog file' button on the side of the drop-down list

After choosing an image, click 'Apply' and 'OK'

Fonts

The fonts used to display on different places like Toolbar, Menu, Window title, Taskbar, Desktop, etc.
can be changed as per user's choice.
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Fig. Changing the display fonts

To change the fonts,

Go to K menu and click on the Control Center

On the 'Appearance and Themes', choose 'Fonts'

Click 'Choose' to choose from the list of fonts and then select their style and size

After choosing a font, click 'OK" and then 'Apply'

Screen Saver

Screen saver is the animated screen that is displayed after certain period of time when the user remains
idle.
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Fig. Changing the Screen Saver

To change the screen saver,

Go to K menu and click on the Control Center

On the 'Appearance and Themes', choose 'Screen Saver'
Choose from the list of screen savers

After choosing the screen saver, click 'Apply'

Splash Screen

Splash screen is the animated screen that is displayed after a user successfully logs in to the system
using any of the graphical user environments (GUI). What is to be kept in mind is that each user can
have a different splash screen as per the user's choice. So whenever a user changes the splash screen, if
takes effect only for that particular user and does not affect the settings of the others.
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To change the splash screen,

Go to K menu and click on the Control Center

On the 'Appearance and Themes', choose 'Splash Screen’

Choose the splash screen of your choice from the list; you can even test the splash screen

After choosing a splash screen, click 'Apply’

KDE Theme

Changing the theme of KDE affects many aspects of one's desktop. For example, background, color,
style, icons, fonts, screen saver, etc. A theme can either be chosen from the list of available themes or a
new theme can be installed from outside. The other option is to customize different components of the
appearance and create a new theme of one's own choice.
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To change the KDE theme,
Go to K menu and click on the Control Center

On the 'Appearance and Themes', choose "Theme Manager'
Choose the theme of your choice from the list

After choosing a theme, click 'Apply'

Similarly, to install a new theme from outside, click on 'Install New Theme' and choose the theme file.
The other option, as we mentioned above, is to customize different components like background,
colors, etc. After customizing different components, click on 'Create a New Theme', enter the required
information and click 'OK. Your newly created theme will be added to the list of available themes,
from where you can choose your theme.

References
http://docs.kde.org/development/en/kdebase/userguide/index.html

7. Publishing with KDE

Text Editor in KDE


http://docs.kde.org/development/en/kdebase/userguide/index.html

KEdit, KWrite, Kate are some of the text editors available in KDE. Although a full-fledged word
processor like OpenOffice.org Writer is available, users can use simple text editors like the ones
mentioned above for simple text editing. In this section, we shall look at using one of the text editors in
KDE Desktop — KWrite.

Note: A text file simply refers to a file which contains pure text printing characters only.

To start KWrite,
Go to K menu

Click Utilities -> Editors -> KWrite
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Fig. Kwrite text editor in KDE

The users can simply type in the KWrite window after the KWrite has started. Both the mouse and
keyboard can be used to move around in the KWrite window. The text can be deleted one character at a
time by using the DELETE /BACKSPACE key or by selecting the text to be deleted and then pressing
the DELETE key to delete a block of text.

To copy, cut and paste the text, select a block of text. Then click on the Edit option on the top menu bar
and select as required. Like,

Edit -> Cut

Edit -> Copy

Edit -> Paste

Similarly, the Undo button on the Edit option can be used to undo the latest changes.

To save the text typed, click on the Save As button on the File option on the main menu as,

File -> Save As...



Go to the folder where you want to save the file and then give the name of the file.

In order to find a text string in the file, the Find button can be used on the Edit menu. Similarly, the
Replace button can be used to find a text string and replace it with another one.

An already saved file on the system can be opened by clicking on the Open button on the File on the
main menu as,

File -> Open

and by selecting the file to open.

To change the preferences like fonts, colors, etc., go to:
Settings -> Configure Editor

For more information on how to use KWrite can be obtained by selecting Help from the menu at the
top.

References
http://www.iosn.net/training/end-user-manual/linux-userguide-kde.odt
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Nepali OpenOffice.org

Nepali OpenOffice.org (OOo0) is a complete office suite in Nepali, featuring a word processor (Writer),
a spreadsheet application (Calc), and presentation software (Impress). Besides these fundamental office
applications, OOo also includes a vector drawing tool (Draw), database access program, publication of
documents in the Portable Document Format (PDF) and presentations in the Flash (SWF) format! The
OOo package is fully inter-operable with the Microsoft Office suite.

Using OpenOffice.org

As a first step for information, it is important to know how the Help system works. To get help:
Help --> Contents

Pay attention to the Options (where you can get help for the individual components in
OpenOffice.org).

Setting up OpenOffice.org preferences makes it work the way you want it . The entire controls for this
are available at:

Tools --> Options

For opening the document whatever you saved in the openOffice.org using the MicroSoft Office
package, always save it in the respective format of the Microsoft package. For eg. For word file .doc
format , for excel .xls and for powerpoint .ppt.

WRITER

This is a powerful tool for creating professional documents, reports, newsletters and so on — it is a word
processor that allows easy integration of charts and pictures, as well as other OpenOffice.org-
compatible documents. It can create anything from a simple letter to books, with professional layouts,
making use of styles.

Start it from the Main Menu by,

Applications --> Office --> OpenOffice.org Writer
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Common Functions

Functions of the word processor can be controlled via the toolbars located at the top of the screen. On
the first row, file actions like opening and saving can be performed, while on the second row, changing
the font, size, and style (bold, underline, or italics) are located.

They can also be controlled by the menus that are common through packages:

* File --> New --> Text Document - Creates a new empty, untitled document for you to work on.

* File --> Open - Opens the file.

* File --> Close - Closes the document you are working on. If changes have been made since your last
save, you will be prompted to save or discard those changes.

* File --> Save - Saves the document you are currently working on.

* File --> Save As... - Saves an updated version of a document in a different location, with a different
name, from the previously saved version.



Common Operations

* To copy text: Select the text with the mouse, then select Edit --> Copy. The selected text is kept in
memory for use elsewhere.

* To paste text: Find the spot where the text needs to be placed, place the cursor there, and then select
Edit --> Paste.

* To cut text: This means that the selected text will be removed from the current location and kept in
memory, to be placed elsewhere. Doing this is exactly like how a copy should be performed, except
selecting Edit --> Cut instead.

* To undo an action: Select Edit --> Undo. It will display the command that it is undoing at the
moment. By browsing the menu, there are also keyboard shortcuts located next to it. Once more
proficient use of the package occurs, it is much quicker to use keyboard shortcuts like

Control+C for Copy, and so on.

Formatting

Some of the quick formatting options are bold, italics and underline. These options are available at the
toolbar at the top of the screen.

Text alignment plays a large role in controlling how portions of the document will look. For example,
an address field at the top of your letter will have such details right-aligned, while the body and rest of
the base text will be left-aligned. There are four-icons that are located next to the bold/italics/underline
icons, providing options such as: right-align, centre-align, left-align and justified.

You can also highlight text and/or its background (like you would with a highlighter and paper!), and
change the font and/or background colours all with the icons there.

Fonts

Changing the font, size, and style (bold, underline, or italics) are located in the second row. This can be
done by highlighting the desired text and clicking the appropriate button.

Others

Writer has a built-in spell checker. This can be accessed via:

Tools --> Spellcheck

The option to auto-spellcheck means that while typing, Writer will dynamically check your spelling,
and if it detects an error, it will output a red-line at the bottom of the misspelled word. Keep in mind

that the spell checking is based on the current language that is in use. This can be
changed via:



Tools --> Options --> Language Settings --> Languages
Nepali Thesaurus can be found by highlighting the word and pressing Ctrl+F7 key.
Accessing word counts in the document is different to most other packages on a default installation of

OpenOffice.org (this can differ with several Linux distributions' offerings):

File --> Properties --> Statistics

It is under the Statistics tab that the word counts and other relevant document counts are based. On
certain vendor modified distributions of OpenOffice.org, going to the Tools -- > Word Count menu will
allow the Statistics dialogue box to be displayed automatically.

CALC

This is the spreadsheet component of the OpenOffice.org package, and contains many useful features,
including an array of functions and plenty of charting options. It is fully inter-operable with Microsoft
Excel, though the function separators differ in the two packages.

CALC may be run opting for Applications --> Office --> OpenOffice.org Calc

or if you already have an existing window of OpenOffice.org open,

File --> New --> Spreadsheet.
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rows and columns, and each row and column combination is called a cell (like Al, B4, and so on).
Upon inputting text into a cell, you might realize that the text is wider than the cell allows — this can be
re-sized via right-clicking the cell, and selecting the Format Cells option. Then under the Alignment
tab, selecting Line Break is what is required.

Formatting

If there is some information that has already been created, and the area should be formatted, one
particular quick and easy option would be to use the AutoFormats available in Calc. This
is done after selecting the area and then opting for:

Format --> AutoFormat

These are pre-defined styles that are available in Calc, and if you have created your own particular
style, you can add them into your new AutoFormats.

In the object toolbar, there is an option to set the font colour within the cell. There are also options to
increase/decrease the indents within a cell, and in the image below, controls for enabling:

* Currency
* Percentage
* Add/Remove significant decimal places

These are quick controls, and accessing them is as simple as clicking the icons that represent them, and
automatically the cell will be formatted as stated. Not only can the borders be set easily, and cell
backgrounds too, but the alignment of text within a cell can also be set. This can be either as top
aligned, centre aligned, or bottom aligned.

Sorting

A big part of dealing with spreadsheets involves a lot of sorting and filtering of data. To sort a dataset,
selecting the active cells, then on clicking

Data --> Sort

will call a pop-up dialogue that has options for sorting the data based on the columns present, as well as
if the data should be ascending or descending.

IMPRESS
No office suite is complete without a presentation piece, and OpenOffice.org shows its colours with
Impress, the presentation piece in the suite. To get started with IMPRESS you need to opt the

following:

Main Menu --> Office --> OpenOffice.org Impress



or if you already have an OpenOffice.org window open, its available at

File --> New --> Presentation
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Unlike other components of OpenOffice.org, when you start Impress, you are presented with an
AutoPilot, to start creating your presentation! This gives you options to start a presentation with an
empty template, or even with one of the pre-defined templates. A preview dialogue is available, and
once all options are selected (and Next is clicked, to move on), you get a basic presentation.

Views

There are several views in Impress, and some have overlapping names, but with different functionality!
Just above the scroll bars, you'll notice five buttons that look like what you see below.

The five options for workspace views are:

* Normal view — normal look of the presentation

* Outline view — overlook of the presentation.

* Notes view — add speaker notes.

* Handout view — how handouts get printed.

* Slide Sorter — birds eye view to add, change, switch slides around.

All the views can also be accessed via:

View --> Workspace



It is also worthwhile to note that at the bottom-left-handcorner of your screen, where the slide tabs are
displayed, there are more views to know about. You are typically located in the Slide View (same name
as above, but different functionality since its on a different bar!)

However, Master Views are supported and to access this view, it is the second button from the left.
You can have master views of all workspace views (i.e. a master view of the slide itself, notes, and
handouts). The Layer view allows layering of slides (adding and removing), and layers can be non-
printing or non-displayed on screen, but printing only.

OpenOffice Draw — A drawing application that lets you add, edit, and align objects; incorporate
textures; include textures and colors; and work with layers of objects.

OpenOffice Math — A calculation program that lets you create mathematical formulas.
Other Word Processors

Other free word processors that come with NepalLinux include Abiword and Gedit.

Ref. 1. http://www.iosn.net/training/end-user-manual/print/linux-userguide-all.pdf
2. OpenOffice.org user guide

8. Fonts Installation and Input System

Font Installation:

Copy the font you want to install

Open Konqueror and type "fonts:/System" in the address bar
Now paste the file. You may be asked to supply root password.
You might have to logout and login to see the effect.
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Alternatively,
1. KDE Menu----->Control Center ----> System Administration ------- > Font Installer

2. Click on Administrator mode and provide root password.
3. Click on Add Fonts, a new window will open , Browse the fonts you want to install.s

Nepali Input System

Adding Nepali Romanized Keyboard Layout
KDE Main Menu --> Control Center --> Regional & Accessibility --> Keyboard Layout

In Layout Tab check "Enable keyboard layouts"
Now from available layouts select Nepal and click on Add >>
Now upon clicking on apply you will notice a layout being added right side of the bottom panel .

m= (9t

Open any text editor and click on the newly added layout. It will switch to nepali
Now you can input in Nepali.

SCIM input system :
In scim input system there are 2 keyboard layout for nepali input. Romanized and Traditional. Just

open any text editor and hit ctrl+space. A small bar will pop up on the right bottom. Now you can



choose between Romanized and Traditional layout by clicking and selecting.
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9. Multimedia and Graphics in KDE
Multimedia

Listening to Audio
It can be launched from KDE Menu--->Multimedia ----> XMMS.
XMMS may need additional plug-ins to be able to play some of the audio file formats.

Audio Player (Amarok)

KDE Menu ----- >Multimedia ----- > Audio Player (Amarok)

Play . Status
@ Stop &  Eject Vol: 40% --/--

M Previous Y Next

Random Loop

Playing VCD and DVD
VLC Media can be used to play both audio and video including VCD and DVD.
You can access the VLC through, KDE Menu ------ > Multimedia ----- > VLC Media Player
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KDE Graphics

Kfrita is a photo retouching, image editing application, but above all, a paint application that will allow
you to create original art on your computer as if you were working with paint and brushes, pencils, pen
and ink.

-, Krita
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KPDF

An advanced PDF viewer, based on xpdf, for KDE. KPDF contains a number of ways to search
through the document (standard find dialog, thumbnail filter, etc.) and has other features such as hands-
free reading.

You can access it as,

KDE Menu ----> Graphics ----> KPDF PDF Viewer



KSnapshot

An application for taking screenshots. It is capable of capturing images of the whole desktop, a single
window, or a selected region. The images can then be saved in a variety of formats, including JPG and
PNG.

You can acces the KSnaspshot as,

KDE Menu ----> Graphics ------ > KSnapshot Screen Capture Program

KView

An image viewer program which supports a number of different image filetypes including JPEG, GIF,
PNG, TIFF and many others. Kview has full integration with KDE and it can be embedded into
Konqueror for viewing image files on your diskdrive as well as your FTP site or webserver, using its
URL open support. Other features include a few image manipulations such as zoom, rotate, grayscale
and flip.

10. Networking with KDE

Assigning IP address
KDE Menu ---->Control Center ------ >Network Setting
Click Administrator Mode button, you are asked to supply root password.
Select the interface and click on Configure Interface button.
Select the automatic or manual as of your requirement.
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For manual setting provide the IP address and subnet mask.

You can add Broadcast address and gateway by clicking advance button.

To provide the DNS address, click on Domain Name System tab and add the DNS address by
clicking add button.

File Sharing

you can share files from one NepaLinux to another NepaLinux using either Samba or NFS(Network
File System).

Right Click on the folder that you want to share,then click on properties
Click on the Share tab
Click on Configure File Sharing
Type the root password
A new window will be shown.
Click on Add
Choose the folder that you want to share
Check "Share with Samba (Microsoft(R) Windows(R))"
Check Writable if you want other users to have write access to the folder otherwise you can leave it
so that it will be read-only.
Click Ok



You have just shared your folder to other NepaLinux and Windows machines.

Accessing Shared Folders
Open the konqueror and type smb://<ip or hostname>

You may have to provide user name and password depending on the types of share.

You can acces the share alternatively as ,
Open the Konqueror.
Click Network Folders.
Click Samba Sharesss

Choose the workgroup that you want to access.

Wireless card configuration using Ndiswrapper(hard disk installation only)

Ndiswrapper is a tool that emulates the windows wireless driver into the Linux system. So you don't
have to worry about the Linux driver for the wireless card. It supports almost all of the wireless
card ,but for these card you must have the driver for windows system.

1. Desktop------ > Administration ----> Windows wireless Tools

2. Now you are asked to enter the root password.

3. Enter the password and click OK.

4. Now click on the Install New Drive r.

= wireless Network Drivers

Currently Installed Windows Drivers:

+ Install Maew Driver |

|
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M Close |

5. Browse the proper .inf file for your wireless card. (Generally from the driver CD of your
Laptop).

= Install Driver

Select inf file:
Location: (Man=) = |

2 cCancel | @mstau



smb:///

6.After you got the proper .inf file, click Install.

% Install Driver

Select inf file:
Location: D net5211.inf [Dl

x Cancel

7. Now your wireless card is detected. You con configure it as usual as of other Ethernet card from the
KDE Menu ----> Control panel ----- >Internet and Network ----- > Network setting

References:
1. User Guide to Using the Linux Desktop.The United Nations Development Programme’s
Asia-Pacific Development Information Programme (UNDP-APDIP), Kuala Lumpur, Malaysia.
2. KDE User guide (docs.kde.org)
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